Trying Aperture 3

I used to use Aperture 2 for all my photos. Recently, though, I’ve taken to only using it for pics from my DSLR (Nikon D90 (Search for "Nikon D90" on: DuckDuckGo, Amazon UK, Amazon US)), and using iPhoto for shots from my compact (Panasonic Lumix FX-550 (Search for "Panasonic Lumix FX-550" on: DuckDuckGo, Amazon UK, Amazon US)). I’ve found myself taking many more shots with the compact, and don’t normally carry the Nikon any more.

That means that for the last few months, I’ve almost exclusively used iPhoto.

When Aperture 3 appeared, it seemed to mix the benefits of Aperture with those of iPhoto, so I grabbed the trial version to have a go.

First impressions were quite good. I imported my iPhoto library, and it seemed to work quite nicely. Then I imported my Aperture library.

Except I didn’t.

I’ve been trying to now for two weeks. Each attempt means leaving it to work all day, or overnight. Every time I return, Aperture has crashed part way through. There doesn’t seem to be any way to get it to continue from where it left off.

There’s been an update from Apple, which addresses just the sort of problems I’ve been having, but it hasn’t helped matters for me.

I even decided to give up on that, and just import the original images again from scratch, losing all the metadata and edits. That crashed somewhere in the middle, too.

This morning, I wanted to post a picture of my breakfast. I opened Aperture 3. It decided it had to process some images and face data in the background, and wasn’t usable while it was doing that. I opened iPhoto and imported the images. Aperture finished it’s background jobs, so I told it to close. I was most of the way through editing and posting the images in iPhoto before Aperture actually got around to closing.

I gather there are some really nice improvements in Aperture 3, but so far, I can’t get to the point where I might care.